您还没登陆呢
 找回密码
 立即注册

QQ登录

只需一步,快速开始

Login

免註冊即享有會員功能

查看: 729|回复: 0
收起左侧

1.6JDK-升至高版本JDK,脚本事件源码读取修改

[复制链接]

该用户从未签到

新人上路

Rank: 1

枫币
97
威望
0
贡献
3
在线时间
11 小时
注册时间
2019-7-14
QQ
发表于 2021-9-28 08:26:55 | 显示全部楼层 |阅读模式
本帖最后由 adminone4 于 2021-9-28 08:30 编辑

开源至上:最近在学习的时候遇到1.8以下的JDK,想着升级一下,于是遇到了一些问题,在1.8之后提供了一个新的Nashorn JavaScript 引擎,它允许我们在虚拟机上运行特定的JavaScript应用。

在启动服务端的时候有可能会报错 “importPakge” 未定义,如果没有报错的请不用管..


修改方法:
    在 scripting 文件夹里找到 AbstractScriptManager 类。

     重要的是画红线的地方,具体为啥这么改,请自行百度.!!


本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?立即注册

x
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

返回顶部